Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Arriba-Sim: Binärdownload für Metropolis (inoffiziell)
#51
Danke Freaky, dann ist der Abschnitt [AgentPreferencesService] in der Arriba obsolet.

Wichtig in der Metro ist aber nach wie vor, die Adressen zu ändern! Sonst crashen die Regionen oder machen anderweitig Probleme, sobald im Grid die Services auf den alten Adressen abgeschaltet werden! Ich nerve hier rum, weil wirklich viele Regionenbesitzer im Metrogrid noch nicht umgestellt haben. Und es wäre schade, wenn Arriba-Nutzer diesbezüglich negativ auffallen.

Also Bewohner der Metro, prüft bitte ob folgende Adressen richtig gesetzt sind:
GridServerURI = "http://grid.hypergrid.org:8000"
AvatarServerURI = "http://avatar.hypergrid.org:8000"
OfflineMessageURL = https://metropolis.hypergrid.org/messaging/offline.php
MuteListURL = https://metropolis.hypergrid.org/messaging/mute.php
SearchURL = "https://metropolis.hypergrid.org/search/query.php"

... und falls ihr XBakes haben wollt:
URL = http://bts.hypergrid.org:8001
Hyperweb.eu => Server-Tutorial für Linux mit OpenSim, OpenSim Arriba compiliert und für Metropolis konfiguriert!
Zitieren
#52
Liebe Arriba-Fans in der Metro!

Es gibt funktionale Neuigkeiten, also nach langer Pause mal wieder ein Update der Metro-Edition.
Zur Erinnerung: Die Binärdateien habe ich aus Freakys Originalquellen erzeugt, die Konfigurationsdateien wurden von mir für das Metropolis-Grid angepasst.

=> Die alten Sculpties dürfen nun auch den Typ "Mesh" haben.
=> Neue OSSL Funktion: "osGetAvatarHomeURI".
=> Diese Version ist jetzt auch unter Mono 4.2 (oder höher) lauffähig.

==> OpenSimArriba_Metro_34c6eb3_16-05-15.zip <==

Interessant ist das Update für Leute, die die neuen Features brauchen oder haben möchten. Vorhandene Konfigurationsdateien können aus der letzten Arriba übernommen werden.

Liebe Grüße,
Mareta
Hyperweb.eu => Server-Tutorial für Linux mit OpenSim, OpenSim Arriba compiliert und für Metropolis konfiguriert!
Zitieren
#53
Liebe Arriba-Fans in der Metro!

Nein, das ist kein Weihnachtsgeschenk ... ich nenne es mal die "Last-16-Edition". Smile
Zur Erinnerung: Die Binärdateien habe ich aus Freakys Originalquellen erzeugt, die Konfigurationsdateien wurden von mir für das Metropolis-Grid angepasst.

Im Laufe der letzten 7 Monate gab es ein paar Bugfixe, und für Gridbetreiber sogar ein neues Feature: Die Robust.ini Konfigurationsdatei kann nun modularisiert werden. Für Regionenserver in der Metro ist das ohne Bedeutung, es bleiben aber die Bugfixes.

==> OpenSimArriba_Metro_1150b4f_16-12-31.zip <==

Interessant ist das Update für Leute, die die mal wieder was aktuelles haben wollen. Vorhandene Konfigurationsdateien können aus der letzten Arriba übernommen werden.

Liebe Grüße und eine schöne Weihnachtszeit,
Mareta
Hyperweb.eu => Server-Tutorial für Linux mit OpenSim, OpenSim Arriba compiliert und für Metropolis konfiguriert!
Zitieren
#54
Ich möchte eine Warnung von Freaky weitergeben:

"Tausche nicht zwischen der Version 0.9 und dem Arriba Fork hin und her. Die Datenbanken sind nicht 100% kompatibel!"

Also ggf. OAR-Backup machen, OpenSim neu aufsetzen mit neuer Datenbank, OAR einspielen...
Hyperweb.eu => Server-Tutorial für Linux mit OpenSim, OpenSim Arriba compiliert und für Metropolis konfiguriert!
Zitieren
#55
Gottseidank habe ich bisher derartige Spielereien unterlassen.Wink
Zitieren
#56
Also das mit der Datenbank war ja schon bei OpenSim 0.8.0 so.
Mir ist durch Arriba die Grid Datenbank kaputt gegangen,
seit dem habe ich da kein Lust mehr auf Arriba.
Jetzt bei der 0.9.1 wird es noch schlimmer,
dann ist da auch Mesh nicht mehr kompatibel.
[Bild: attachment.php?aid=2586]


Zitieren
#57
Eigentlich ist es ja selbstverständlich, beim Downgrading auf eine ältere Version, oder gar beim Wechsel zwischen verschiedenen Forks, die Datenbank zu verwerfen.

Ich wäre gar nicht auf die Idee gekommen, davor explizit zu warnen. Confused

EDIT: Die Arriba ist ein Fork aus der 0.8.2, und irgendwelche Anpassungen an 0.9.x sind nicht mehr vorgesehen. Sie passt wunderbar zur Metropolis-Edition, und ich habe viele Male zwischen den beiden Versionen gewechselt. Allerdings habe ich immer die Datenbank verworfen und ein OAR-Backup in eine frische Datenbank eingespielt! Sollte irgendwann die Metro auf 0.9 wechseln, dann war's das eben mit der Arriba dort. Zur Zeit kann ich im Metro-Grid die Metro-Edition und OpenSim Arriba wärmstens empfehlen, beide gefallen mir im Metro-Grid hervorragend. Und darum geht es ja in diesem Thread: Arriba Binärdownload fürs Metropolis Grid.
Hyperweb.eu => Server-Tutorial für Linux mit OpenSim, OpenSim Arriba compiliert und für Metropolis konfiguriert!
Zitieren
#58
Liebe Arriba-Fans in der Metro!

Die "Last-16-Edition" liegt ein halbes Jahr zurück, und die Arriba hat seitdem 23 Änderungen erfahren. Davon wirken sich 12 direkt auf die Binaries aus, die anderen Änderungen betreffen Kommentare und die Konfigurationsbeispiele.

Zeit für eine "Sommer-Edition "! Big Grin
Zur Erinnerung: Die Binärdateien habe ich aus Freakys Originalquellen erzeugt, die Konfigurationsdateien wurden von mir für das Metropolis-Grid angepasst.

==> OpenSimArriba_Metro_324588c_17-07-02.zip <==

Liebe Grüße,
Mareta
Hyperweb.eu => Server-Tutorial für Linux mit OpenSim, OpenSim Arriba compiliert und für Metropolis konfiguriert!
Zitieren
#59
Liebe Arriba-Fans in Metropolis!

Ihr habt sicherlich schon mitbekommen, dass demnächst das Metropolis Grid auf eine 0.9.x Version umgestellt wird.

Die Arriba ist ein Fork von OpenSim 0.8.x und eine Weiterentwicklung des Forks (außer Fehlerbehebungen) ist nicht geplant. Damit wird OpenSim Arriba inkompatibel zum Metropolis Grid.

Deshalb werde ich nach dem Umstieg des Metropolis Grids keinen Binärdownload für Metropolis mehr anbieten. Wer einen Binärdownload für andere Grids braucht, kann "neutrale" Downloads weiterhin direkt von Freaky bekommen:

https://github.com/ft-/arribasim-techpreview-builds

Liebe Grüße,
Mareta
Hyperweb.eu => Server-Tutorial für Linux mit OpenSim, OpenSim Arriba compiliert und für Metropolis konfiguriert!
Zitieren
#60
Liebe Arriba-Fans in der Metro!

Freaky hat subtile Unterschiede beim Stream-Handling zwischen .NET und Mono gefunden. Diese führten unter Mono zu Fehlern im HTTP-Server. Deshalb gibt es nun eine korrigierte Variante in einem neuen Build.

Bereits vorhandene Konfigurationsdateien aus der letzten Arriba können unverändert übernommen werden.

Zur Erinnerung: Die Binärdateien habe ich aus Freakys Originalquellen erzeugt, die Konfigurationsdateien wurden für das Metropolis-Grid angepasst.

==> OpenSimArriba_Metro_106fd86_17-10-02.zip <==

Liebe Grüße,
Mareta
Hyperweb.eu => Server-Tutorial für Linux mit OpenSim, OpenSim Arriba compiliert und für Metropolis konfiguriert!
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  "Arriba-Minigrid" (Windows) Dorena Verne 108 76.215 02.09.2018, 12:42
Letzter Beitrag: Dorena Verne
  neue Version von Arriba on Stick Beacara 40 24.432 22.02.2018, 12:40
Letzter Beitrag: Beacara
  "Arriba-Minigrid" Shop-Region-Projekt Dorena Verne 4 1.200 21.01.2018, 17:01
Letzter Beitrag: Dorena Verne
  Mesh-Problem Arriba Dorena Verne 10 4.335 06.08.2017, 08:31
Letzter Beitrag: Dorena Verne
  Umzug von Opensim nach Arriba Pharcide 3 3.096 14.08.2016, 15:34
Letzter Beitrag: Dorena Verne

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste