Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
OpenSim auf V-Server installieren
#1
Hallo Ihr Lieben, 

möchte gerne auf meinem V-Server Ubuntu 14 ne eigene SIM Installieren und ankoppeln und zum laufen bringen. 
Bin nach der Anleitung von hypergrid.org/metropolis gegangen und komme nicht wirklich weiter. 

Hab die Version metropolis-os_083_DEV_PLUS_LINUX.zip genommen.

Install und OpenSimsoftware ist schon in Ordnern gepackt, Regions.ini 
opensim.sh etc. alles gemacht/geändert und erstellt auch chmod rechte entsprechend gesetzt...

DB Hab ich auch erstellt im Plesk, weiss nicht ob das richtig war ?!  Huh

Beim Start über Putty passiert nicht wirklich was und ne noch genauere Anleitung, als bei Hypergrid find ich auch hier nicht im Forum. 

Wäre wirklich sehr über Hilfe dankbar, bei fragen einfach drauf los Smile

Vielen Dank im Voraus
Zitieren
#2
Hallo Rivi ;D

Erstmal Herzlich Willkommen in unseren kleinen Forum ;D

Zu deinem Problem, poste mal die Region.ini. Soweit ich weiss muss du keine DB installieren, aber bin mir nicht so sicher.
Tschöö

Bogus | PinguinsReisen.de
Zitieren
#3
Auch von mir ein herzliches Willkommen bei uns im Gridtalk, Rivi. Smile

Poste doch mal die Ausgabe von Putty.

Des weiteren kann ich dir sehr die Anleitung von Mareta ans Herz legen:
https://hyperweb.eu/Willkommen
Zitieren
#4
@Bogus 

Danke, hier die Regions.ini

[SimName]
 ;RegionUUID = "Semikolon-entfernen-und-UUID-einfuegen-beim-Start"
 Location = "7002,7013" ; freie Koordinaten aus dem Worldraster suchen
 InternalAddress = "0.0.0.0"
 InternalPort = 9051
 AllowAlternatePorts = False
 ExternalHostName = "xx.xx.xx.xxx"

@Dorena

Vielen Dank, 

Hier die Putty befehle : 

starten: 

./opensim.sh > /dev/null 2>&1 &

[1] 6066

screen Kontrolle:

root@xxx:~# screen -ls

No Sockets found in /var/run/screen/S-root.

[1]+  Exit 127                ./opensim.sh > /dev/null 2>&1


Mein die Anleitung schon mal gelesen zu haben, aber schaue sie mir nochmal genau an Smile Danke
Zitieren
#5
Herzlich willkommen, Rivi!

Dorena hat meine Anleitung schon verlinkt. Bitte beachte bei Ubuntu 14.04 insbesondere auch den Kompatibilitätshinweis (https://hyperweb.eu/Ubuntu_14.04/Paketauswahl ziemlich weit unten auf der Seite). Es gibt leider viele Kombinationen aus Mono, Linux-Kernel und Opensim, die nicht stabil laufen. Wenn es bei deinem Provider möglich ist, starte besser gleich mit 16.04 durch: Die rockt (abgesehen von Performance-Tuning) ohne was nacharbeiten zu müssen.

EDIT: Wenn du "screen" verwendest, brauchst du "tmux" natürlich nicht, das ist nur ein anderes Programm für den gleichen Zweck. Mit Screen hatte ich in der Vergangenheit öfters Probleme, weshalb ich auf Tmux umgestiegen bin.

Liebe Grüße,
Mareta
Hyperweb.eu => Server-Tutorial für Linux mit OpenSim, OpenSim Arriba compiliert und für Metropolis konfiguriert!
Zitieren
#6
Danke, ja ist problemlos möglich, soweit ich weiss was die Version angeht. 

tmux hab ich nie benutzt, nutze nur Screen muss mich da mal schlau machen Smile 

Setz ich wohl alles neu auf was den Simulator angeht, oder kann der so bleiben ?

LG
Zitieren
#7
Hallo

ich gehe davon aus, das du dich an metro andocken willst? auch wenn in der anleitung nur die nat-regeln fuer router aufgefuehrt sind https://hypergrid.org/metropolis/wiki/en...rbereitung , musst du diese ports in deiner firewall frei geben https://hyperweb.eu/Ubuntu_16.04/Firewall .
ska@jabber.ccc.de            
skaduwee@jabber.ccc.de

diese Signatur ist in deinem Land nicht verfügbar :-P
Zitieren
#8
Hallo, 

ja richtig das hatte ich vor, um in die Materie reinzukommen mal Smile 
Na dann muss ich wohl ans Bash Skript und schauen wie ich das mach. 

LG und danke dir Smile
Zitieren
#9
Falls du noch keine Firewall hast, also weder du noch dein Serververmieter eine eingerichtet hat, dann hat Ubuntu erst mal keine Firewall. Natürlich ist es auf Dauer sinnvoll eine einzurichten, aber du musst dich nicht als erstes gerade darauf stürzen. Und wenn du mit Screen gut klar kommst, muss auch kein Tmux sein: Bei mir ging Screen in verschiedenen Linux-Versionen schlecht (z.B. nicht farbig) und da hatte ich es halt vor Jahren mal ausgetauscht. Für vieles gibt es mehr als eine Lösungsmöglichkeit. Wink
Hyperweb.eu => Server-Tutorial für Linux mit OpenSim, OpenSim Arriba compiliert und für Metropolis konfiguriert!
Zitieren
#10
Ne ich hatte keine, so wie ich das gesehen hab, die hab ich nun glaub ich jedenfalls eingerichtet. 

Komme trotzdem nicht weiter und ich hab keine Ahnung wo das Problem sein könnte. 

Screen kenne ich von früher noch von TS Servern, oder Gameservern etc. drum hatte ich nie Probs mit, naja ist ja auch net schlimm nun. 

Muss nur irgendwie weiter gehen, wenn ich nur wüsste wie. 
Ob alles neu machen, also altes Opensim löschen, per Putty draufspielen und schauen.. Hmm

Wobei ich glaub das muss nichtmal sein, liegt wohl an irgendeiner Datei oder Funktion
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Server-Tutorial: OpenSuse Linux und OpenSim Mareta Dagostino 24 9.388 07.10.2017, 23:02
Letzter Beitrag: Mareta Dagostino
  Root.-,Virtual.- oder Home-Server am Grid andocken? Lupopa Grau 4 262 12.09.2017, 19:57
Letzter Beitrag: Lupopa Grau
  OpenSim Release 0.9.0.0 ist da Dorena Verne 18 1.007 01.09.2017, 14:38
Letzter Beitrag: Bogus Curry
  [OPENSIM] Parzellen erstellen Lupopa Grau 11 716 16.08.2017, 10:49
Letzter Beitrag: Leora Jacobus
  Opensim zeigt bei uns am Avatar IP statt den Gridnamen Lupopa Grau 9 708 10.08.2017, 15:07
Letzter Beitrag: Lupopa Grau

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste