Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
OpenSim auf V-Server installieren
#11
OpenSim brauchst du ja nicht gleich löschen. Du kannst auf MariaDB (oder MySQL) einfach eine weitere Datenbank einrichten, z.B. "OpenSimTest", das "bin" Verzeichnis umbenennen in z.B. "bin_", dann einen anderen Versuch in ein frisches bin Verzeichnis legen. Dort gibst du dann in GridCommon.ini die Test-Datenbank an und machst dir nichts am Original kaputt.

EDIT: Das bin-Verzeichnis solltest du nicht umbenennen, während OpenSim läuft. Also vorher OpenSim beenden und danach neu starten...
Hyperweb.eu => Server-Tutorial für Linux mit OpenSim, OpenSim Arriba compiliert und für Metropolis konfiguriert!
Zitieren
#12
huhu Rivi

wenn du die metropolis-os_XXXXXX_LINUX.zip benutzt, ist die bis auf anpassungen in der Regions.ini alles fertig. Hast du es einfach mal ohne aenderungen an der db versucht? Bei den worten "No Sockets found" konnte ich mich dunkel an aehnliche fehler bei mir bei fehler im router erinnern. kann natuerlich auch voellig ander ursache haben. ich muss mal bei gelegenheit den portfehler provozieren.

viele gruesse
ska@jabber.ccc.de            
skaduwee@jabber.ccc.de

diese Signatur ist in deinem Land nicht verfügbar :-P
Zitieren
#13
So ich komm der Sache langsam näher, jetzt hab ich den Simulator gestartet mitm Befehl mono OpenSim.exe
und  bekomme folgende Fehlermeldung, hier ein Auszug aus dem OpenSim.log

2017-09-27 13:17:40,760 INFO  - OpenSim.OpenSim [OPENSIM MAIN]: Using async_call_method SmartThreadPool
2017-09-27 13:17:40,790 INFO  - OpenSim.OpenSim ====================================================================
2017-09-27 13:17:40,790 INFO  - OpenSim.OpenSim ========================= STARTING OPENSIM =========================
2017-09-27 13:17:40,790 INFO  - OpenSim.OpenSim ====================================================================
2017-09-27 13:17:40,806 INFO  - OpenSim.Framework.Servers.ServerBase [SERVER BASE]: Starting in /var/www/vhosts/.../.../Opensim/bin
2017-09-27 13:17:40,809 INFO  - OpenSim.Framework.Servers.ServerBase [SERVER BASE]: OpenSimulator version: OpenSim 0.8.3.0 Dev PLUS Metropolis Edition [018]      
2017-09-27 13:17:40,809 INFO  - OpenSim.Framework.Servers.ServerBase [SERVER BASE]: Operating system version: Unix 3.13.0.42, .NET platform Unix, 64-bit
2017-09-27 13:17:40,816 INFO  - OpenSim.Framework.Servers.ServerBase [SERVER BASE]: Logging started to file /var/www/vhosts/.../.../Opensim/bin/OpenSim.log
2017-09-27 13:17:41,304 INFO  - OpenSim.Framework.Servers.HttpServer.BaseHttpServer [BASE HTTP SERVER]: Starting HTTP server on port 9000
2017-09-27 13:17:41,385 ERROR - OpenSim.Framework.Servers.HttpServer.BaseHttpServer [BASE HTTP SERVER]: Error - Address already in use
2017-09-27 13:17:41,385 ERROR - OpenSim.Framework.Servers.HttpServer.BaseHttpServer [BASE HTTP SERVER]: Tip: Do you have permission to listen on port 9000, 0?
2017-09-27 13:17:41,389 ERROR - OpenSim.Application [APPLICATION]: 
APPLICATION EXCEPTION DETECTED: System.UnhandledExceptionEventArgs

Exception: System.Net.Sockets.SocketException (0x80004005): Address already in use
  at OpenSim.Framework.Servers.HttpServer.BaseHttpServer.Start (System.Boolean performPollResponsesAsync) [0x00177] in <963307d0624a4b0f8e5327f384695eb6>:0 
  at OpenSim.Framework.Servers.HttpServer.BaseHttpServer.Start () [0x00000] in <963307d0624a4b0f8e5327f384695eb6>:0 
  at OpenSim.RegionApplicationBase.StartupSpecific () [0x00091] in <f2fa3fb5abdc4c5f9374c37bb3a8c92d>:0 
  at OpenSim.OpenSimBase.StartupSpecific () [0x00171] in <f2fa3fb5abdc4c5f9374c37bb3a8c92d>:0 
  at OpenSim.OpenSim.StartupSpecific () [0x00101] in <f2fa3fb5abdc4c5f9374c37bb3a8c92d>:0 
  at OpenSim.Framework.Servers.BaseOpenSimServer.Startup () [0x00000] in <2644c8ace5cc406985d9ae7eabce1b56>:0 
  at OpenSim.Application.Main (System.String args) [0x003c2] in <f2fa3fb5abdc4c5f9374c37bb3a8c92d>:0 

Application is terminating: True


Nun weiss ich nicht wirklich weiter  Huh

Liebe Grüße
Zitieren
#14
Jetzt hab ich es mal hinbekommen, nur gehört meine SIM jetzt nem TestUser, weil ich verpeilt hab meinen Ava einzutragen, 
kann ich das wieder ändern, oder die Sim wieder löschen und mit richtigen Daten eintragen ? 

Weil die UUID am anfang beim Start hab ich mir kopiert, hat sich Putty aufgehangen für die Region. ini

Schlimm echt, ich weiss  Big Grin
Zitieren
#15
Hallo Rivi

auch ich heisse Dich willkommen hier im Forum Smile

du könntest mit HeidiSQL verbinden auf die Datenbank, suchst nach der Tabelle Users oder ähnlich und änderst darin Dein Namen, aber nicht die UUID

Grüsse, Pharcide
Zitieren
#16
Huhu Rivi,

Wilkommen im Gridtalk-Forum. Vermutlich hast Du auf Deiner Region noch nicht so sonderlich viel gebaut, da ist es wohl einfacher, die Region zu löschen und eine neue zu starten - diesmal eben mit den richtigen Angaben. Da Du die MetroEdition nutzt vermute ich mal, dass Deine Region im MetroGrid angemeldet ist. Nun ist aber der TestUser der Eigentümer, und so kannst Du sie leider nicht selber aus der Datenbank löschen. Dazu müsstest Du eine Nachricht mit dem Namen der Region an Lena Vanilli (oder mich) schicken. Ansonsten kannst Du in dem Metropolis-Webinterface  Deine Region(en) verwalten.

Ciaoo

Sheera
Zitieren
#17
Hallo 

@ Pharcide , Danke. Hab das HeidiSQL Grad installiert, aber kA wie ich da reinkomm mit welchen Daten, root geht schon mal nicht, meine DB is das auch  nicht, welche ich erstellt hab, hmm.

Sheera Danke auch Dir Smile Ne gebaut garnicht, war ja nicht mal drauf, wenn ich versuche drauf zu gehen, weil da ist sie schon, aber da kommt
"Service request failed: Error: ConnectFailure (Connection refused)" bei nem TP dorthin. 

ne Nachricht schick ich dir per Pn jetzt, Webinterface müsstest du mir sagen,wo ich das find Smile
Zitieren
#18
Das Webinterface zum Verwalten der eigenen Regionen im Metropolis Grid ist:
https://metropolis.hypergrid.org/regioman.php

Allerdings geht das nur mit dem Account, der auch Besitzer der Region ist. Solltest du also das Passwort des Test-Users noch kennen, kannst du (neben vielen anderen interessanten Sachen) dessen Region mit dem verlinkten Tool löschen, ohne selber OpenSim laufen zu haben.

Wenn du das Passwort nicht mehr kennst und an der gleichen Position im Grid eine Region mit dem richtigen Account haben willst, können nur die Metro-Admins helfen, siehe @Sheera.
Hyperweb.eu => Server-Tutorial für Linux mit OpenSim, OpenSim Arriba compiliert und für Metropolis konfiguriert!
Zitieren
#19
Du kannst den Eigentümer deiner Region in der DB ändern. Dazu gehst du in die DB von deiner Region unter "estate_settings" und kannst dort die UUID des Eigentümers ändern. Wenn du die Region dann neu startest ist die Region auf dem neuen Avatar. 
Dies betrifft dann auch die Grid DB und du hast die Region in deinem metro regions manager.


[Bild: ?f=3bozxvcky7or96ki]
Zitieren
#20
Vielen Dank, aber den Test User habe icht nicht selber erstellt, oder ist der beim durchklicken in Putty entstanden ? 
Hmm da kam was mit ersetzen hinzufügen etc. aber ich hab Enter gedrückt drum kam es so wie es ist Smile
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Server-Tutorial: OpenSuse Linux und OpenSim Mareta Dagostino 24 9.384 07.10.2017, 23:02
Letzter Beitrag: Mareta Dagostino
  Root.-,Virtual.- oder Home-Server am Grid andocken? Lupopa Grau 4 262 12.09.2017, 19:57
Letzter Beitrag: Lupopa Grau
  OpenSim Release 0.9.0.0 ist da Dorena Verne 18 1.007 01.09.2017, 14:38
Letzter Beitrag: Bogus Curry
  [OPENSIM] Parzellen erstellen Lupopa Grau 11 716 16.08.2017, 10:49
Letzter Beitrag: Leora Jacobus
  Opensim zeigt bei uns am Avatar IP statt den Gridnamen Lupopa Grau 9 708 10.08.2017, 15:07
Letzter Beitrag: Lupopa Grau

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste