Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Mono update sinnvoll?
#1
Hallo zusammen, habe ja kürzlich mein System mit Hilfe aus dem Forum auf mysql umgestellt.
Es ruckelt immer noch heftig (sich bewegen und rezzen). Ich habe folgenden V-Server: Klick
Darauf läuft:  Debian Linux 7, Linux 3.2.0-5-amd64 auf x86_64 mit Mono JIT compiler version 2.10.8.1 (Debian 2.10.8.1-8+deb7u1)

Auf der Sim sind ca. 300 Skripte. Gerezzt sind ca. 5500 Objekte. Ich hatte auf einem kleineren Server auf 4 Sims schon
weit über 20.000 Objekte drauf und nie Probleme. Plötzlich dieser lag, kann das evtl an der veralteten mono-Version liegen?
falls ja, wie installiere ich auf Debian eine aktuelle Version. Wie geht das deinstallieren der älteren Version? Danke.

Edit.: Gestern habe ich das Backup der Sim auf meinem PC installiert, dort läuft alles problemlos und ohne ruckeln

LG
Raul
Zitieren
#2
Schau mal:
http://www.mono-project.com/download/sta...lin-debian
Zitieren
#3
Ich vermute mal, dass der Lag eher an den Netzwerkverbindungen oder am Server selber liegt. In letzter Zeit habe ich im Metropolis-Forum vermehrt über Probleme gelesen, die ich schlechten Netzwerkverbindungen zuordne.

Ich würde an deiner Stelle mal die beteiligten Verbindungen möglichst in beide Richtungen mit MTR oder WinMTR (unter Windows) testen. Vielleicht gibt das mehr Aufschluss. Ergeben sich daraus erste Hinweise, dann kann ich bei der weiteren Analyse und der Auswertung der MTR-Logs gerne behilflich sein.
[-] The following 1 user says Thank You to Pius Noel for this post:
  • Raul Gonzales
Zitieren
#4
Ich danke für die schnellen Antworten. Smile


Auf mtr -s 1000 -r -c 1000 www.telia.de wird mir folgendes ausgegeben:
Code:
HOST: vmd18444.contaboserver.net  Loss%   Snt   Last   Avg  Best  Wrst StDev
  1.|-- ip-1-75-136-213.static.co  0.1%  1000    0.3   1.2   0.2  35.9   4.6
  2.|-- ffm-b11-link.telia.net     0.1%  1000    0.5   1.1   0.5  28.9   2.6
  3.|-- hbg-bb1-link.telia.net     0.0%  1000   41.0  38.0  22.4 162.4  26.5
  4.|-- kbn-bb3-link.telia.net     0.0%  1000   22.9  22.4  22.0  33.9   0.9
  5.|-- kbn-b2-link.telia.net      0.0%  1000   22.3  22.8  21.9  51.2   2.4
  6.|-- ld-h-peer4-link.telia.net  0.0%  1000   22.5  24.0  22.5 124.2   6.9
  7.|-- m-b-c2-link.se.telia.net   0.0%  1000   23.2  23.4  23.0  31.8   0.8
  8.|-- fre-c2-link.se.telia.net   0.0%  1000   35.3  35.2  34.7  51.5   0.9
  9.|-- hdn-r-sec1-link.se.telia.  0.0%  1000   34.9  34.7  34.4  44.6   0.6
 10.|-- 90.228.166.164             0.1%  1000   36.0  35.8  35.4  44.6   0.8
 11.|-- ???                       100.0  1000    0.0   0.0   0.0   0.0   0.0

ich kann allerdings damit nichts anfangen.
Zitieren
#5
Das sieht jetzt vom Server zu telia.de schon mal nicht so schlecht aus. Wichtig ist der Durchschnitt (Spalte avg) und der Paket Loss am Ziel. Der Loss von 0.1% ist vernachlässigbar. Mit den bei dir angezeigten Werten solltest du kein Lag haben.

Was im Schnitt unter 100 liegt und kein Loss ausweist ist schon mal ok. Soviel habe ich in etwa zum OSGrid. Das ist zwar nicht besonders schnell aber o.k. Zu Secondlife habe ich um die 160.

Mit dem gleichen Test von meinem Server bei Hetzner zu telia.de erreichte ich sogar einen marginal geringeren Wert (36.4 statt 35.8 ms). In netzwerktechnischer Hinsicht dürfte ein Providerwechsel (von C* zu H*) also nichts bringen.

Aber leider ist das noch nicht alles. Du solltest immer von Rechner zu Rechner messen (also deinen PC zum Server) und das wenn immer möglich in beide Richtungen. Als erstes eigentlich vom PC zum Server, dann ggf. noch umgekehrt vom Server möglichst nah an den PC. Wenn du an ein Grid angeschlossen bist, spielt die Verbindung vom PC zum Grid auch noch eine wichtige Rolle und letztendlich auch noch die Verbindung vom Server mit deiner Region zu den Gridservices.

Noch etwas: mtr basiert wie Traceroute und Ping auf ICMP. Das dürfte also in der Firewall nicht abgeklemmt sein, damit die Tests durchgeführt werden können. Leider ist das je nach Anschluss beim Provider nicht immer möglich.
[-] The following 3 users say Thank You to Pius Noel for this post:
  • Anachron, Bogus Curry, Dorena Verne
Zitieren
#6
Bist du an ein Grid angeschlossen oder betreibst du auf dem Server dein eigens Grid (Mini Grid, Diva, Stand Alone, was auch immer)? Falls Sim mit Gridanschluss, welches? Und welche OpenSimulator Software verwendest du (Ausgabe, Version... z.B OpenSim 0.8.3.0 Dev PLUS Metropolis Edition [018] oder OpenSim 0.9.1.0 Dev etc)?

Ich habe dir noch eine PN geschickt.
Zitieren
#7
Habe nun auf Debian 9 umgestellt, mit sqlite läuft alles ganz gut, wenn ich allerdings
auf Mysql umstelle bekomme ich Fehlermedungen. Ich komme nicht weiter. Hat
jemand einen Tipp für mich, bitte?
Zitat:18:01:24 - [SERVER BASE]: Operating system version: Unix 4.9.0.6, .NET platform Unix, 64-bit
Console log level is ALL
18:01:24 - [SERVER BASE]: Logging started to file /usr/games/bin/OpenSim.log
18:01:24 - [SERVICE BASE]: Failed to load plugin OpenSim.Region.Framework.Interfaces.ISimulationDataStore from OpenSim.Data.MySQL.dll with args Data Source=localhost;Database=opensim;User ID=Raul;Password=xxxxxxEmma;Old Guids=true;System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> MySql.Data.MySqlClient.MySqlException: Access denied for user 'Raul'@'localhost' (using password: YES)
  at MySql.Data.MySqlClient.MySqlStream.ReadPacket () [0x00064] in <0a4f02a6a627411ca7a0cb7f962401d6>:0
  at MySql.Data.MySqlClient.NativeDriver.AuthenticateNew () [0x0008b] in <0a4f02a6a627411ca7a0cb7f962401d6>:0
  at MySql.Data.MySqlClient.NativeDriver.Authenticate () [0x00016] in <0a4f02a6a627411ca7a0cb7f962401d6>:0
  at MySql.Data.MySqlClient.NativeDriver.Open () [0x002d1] in <0a4f02a6a627411ca7a0cb7f962401d6>:0
  at MySql.Data.MySqlClient.Driver.Open () [0x0000b] in <0a4f02a6a627411ca7a0cb7f962401d6>:0
  at MySql.Data.MySqlClient.Driver.Create (MySql.Data.MySqlClient.MySqlConnectionStringBuilder settings) [0x00029] in <0a4f02a6a627411ca7a0cb7f962401d6>:0
  at MySql.Data.MySqlClient.MySqlPool.CreateNewPooledConnection () [0x00000] in <0a4f02a6a627411ca7a0cb7f962401d6>:0
  at MySql.Data.MySqlClient.MySqlPool.GetPooledConnection () [0x00083] in <0a4f02a6a627411ca7a0cb7f962401d6>:0
  at MySql.Data.MySqlClient.MySqlPool.TryToGetDriver () [0x0001e] in <0a4f02a6a627411ca7a0cb7f962401d6>:0
   --- End of inner exception stack trace ---
  at System.Reflection.MonoCMethod.InternalInvoke (System.Object obj, System.Object parameters) [0x00019] in <8f2c484307284b51944a1a13a14c0266>:0
  at System.Reflection.MonoCMethod.DoInvoke (System.Object obj, System.Reflection.BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object parameters, System.Globalization.CultureInfo culture) [0x00089] in <8f2c484307284b51944a1a13a14c0266>:0
  at System.Reflection.MonoCMethod.Invoke (System.Reflection.BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object parameters, System.Globalization.CultureInfo culture) [0x00000] in <8f2c484307284b51944a1a13a14c0266>:0
  at System.RuntimeType.CreateInstanceImpl (System.Reflection.BindingFlags bindingAttr, System.Reflection.Binder binder, System.Object args, System.Globalization.CultureInfo culture, System.Object activationAttributes, System.Threading.StackCrawlMark& stackMark) [0x00243] in <8f2c484307284b51944a1a13a14c0266>:0

18:01:24 - [SERVER UTILS]: Error loading plugin OpenSim.Region.Framework.Interfaces.ISimulationDataService from OpenSim.Services.SimulationService.dll. Exception: Could not find a storage interface in the given moduleSystem.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.Exception: Could not find a storage interface in the given module
  at OpenSim.Services.SimulationService.SimulationDataService.LoadPlugin[T] (System.String dllName) [0x000b3] in <526c8f5220224790a285438d721469d9>:0
  at (wrapper managed-to-native) System.Reflection.MonoCMethod:InternalInvoke (System.Reflection.MonoCMethod,object,object,System.Exception&)
  at System.Reflection.MonoCMethod.InternalInvoke (System.Object obj, System.Object parameters) [0x00002] in <8f2c484307284b51944a1a13a14c0266>:0
   --- End of inner exception stack trace ---
  at System.Reflection.MonoCMethod.InternalInvoke (System.Object obj, System.Object parameters) [0x00019] in <8f2c484307284b51944a1a13a14c0266>:0
  at System.Reflection.MonoCMethod.DoInvoke (System.Object obj, System.Reflection.BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object parameters, System.Globalization.CultureInfo culture) [0x00089] in <8f2c484307284b51944a1a13a14c0266>:0
  at System.Reflection.MonoCMethod.Invoke (System.Reflection.BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object parameters, System.Globalization.CultureInfo culture) [0x00000] in <8f2c484307284b51944a1a13a14c0266>:0
  at System.RuntimeType.CreateInstanceImpl (System.Reflection.BindingFlags bindingAttr, System.Reflection.Binder binder, System.Object args, System.Globalization.CultureInfo culture, System.Object activationAttributes, System.Threading.StackCrawlMark& stackMark) [0x00243] in <8f2c484307284b51944a1a13a14c0266>:0

18:01:24 - [SERVER UTILS]: Error loading plugin OpenSim.Services.SimulationService.dll: Exception has been thrown by the target of an invocation. args.Length 1
18:01:24 - [APPLICATION]:
APPLICATION EXCEPTION DETECTED: System.UnhandledExceptionEventArgs

Exception: System.Exception: Could not load an ISimulationDataService implementation from OpenSim.Services.SimulationService.dll:SimulationDataService, as configured in the LocalServiceModule parameter of the [SimulationDataStore] config section.
  at OpenSim.OpenSimBase.StartupSpecific () [0x000e5] in <f2fa3fb5abdc4c5f9374c37bb3a8c92d>:0
  at OpenSim.OpenSim.StartupSpecific () [0x00101] in <f2fa3fb5abdc4c5f9374c37bb3a8c92d>:0
  at OpenSim.Framework.Servers.BaseOpenSimServer.Startup () [0x00000] in <2644c8ace5cc406985d9ae7eabce1b56>:0
  at OpenSim.Application.Main (System.String args) [0x003c2] in <f2fa3fb5abdc4c5f9374c37bb3a8c92d>:0

Application is terminating: True

[ERROR] FATAL UNHANDLED EXCEPTION: System.Exception: Could not load an ISimulationDataService implementation from OpenSim.Services.SimulationService.dll:SimulationDataService, as configured in the LocalServiceModule parameter of the [SimulationDataStore] config section.
  at OpenSim.OpenSimBase.StartupSpecific () [0x000e5] in <f2fa3fb5abdc4c5f9374c37bb3a8c92d>:0
  at OpenSim.OpenSim.StartupSpecific () [0x00101] in <f2fa3fb5abdc4c5f9374c37bb3a8c92d>:0
  at OpenSim.Framework.Servers.BaseOpenSimServer.Startup () [0x00000] in <2644c8ace5cc406985d9ae7eabce1b56>:0
  at OpenSim.Application.Main (System.String args) [0x003c2] in <f2fa3fb5abdc4c5f9374c37bb3a8c92d>:0
Zitieren
#8
Hast du zuerst eine datenbak für opensim angelegt? hat der user dafür entsprechende Rechte?
sieht nicht so aus, da: Access denied for user 'Raul'@'localhost' (using password: YES)
Zitieren
#9
Danke für die schnelle Rückmeldung Dorena. Ja User ist angelegt, ich habe
nichts anderes gemacht wie mit der mysql DB in Debian 7, damit lief
es ja sofort, (allerdings nicht rund, deshalb ja die Umstellung).

LG
Zitieren
#10
Schau nochmal genau in die ini, ob sich da nicht ein kleiner sytaxfehler eingeschlichen hat,...beispielweise das xxxxx.
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Debian 8, Welche Mono Version ... Raul Gonzales 15 1.220 15.03.2018, 22:13
Letzter Beitrag: Bartholomew Gallacher
  Mono 5.0 veröffentlicht Bogus Curry 0 721 22.05.2017, 19:03
Letzter Beitrag: Bogus Curry
  Sim on a Stick Geh und Stand-Animationen? Update auf OS 0.8.2.1 möglich??? bengl1984 4 2.076 02.01.2017, 18:18
Letzter Beitrag: Bogus Curry
Wink Mono 4.4 SR1 (4.4.2.11) Wollex Baily2 10 4.234 11.09.2016, 09:15
Letzter Beitrag: Dorena Verne
  Mono 4.0.1 ist draussen Anette Hummel 8 5.181 07.05.2015, 12:44
Letzter Beitrag: Anette Hummel

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste