Themabewertung:
  • 1 Bewertung(en) - 5 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Groups Profile und CO
#41
Ich hab eben nochmal alles komplett gelöscht und alle Einstellungen neu gemacht, leider wollen die Profile nicht, keine Ahnung warum ...

Muss man evtl. den Grid oder Hypergrid Modus aktivieren?

Lukas Smile
Zitieren
#42
Am Hypergrid liegt es definitif nicht. Hast du wirklich das kopiert was ich geschrieben habe? Das ist ein Auszug aus der aktuellen Version müsste also eigendlich laufen. Undecided
Zitieren
#43
Ich poste hier mal alle von mir geänderten Dateien:

OpenSim.ini
Zitat:[UserProfiles]
;# {ProfileURL} {} {Set url to UserProfilesService} {}
;; Set the value of the url to your UserProfilesService
;; If un-set / "" the module is disabled
ProfileServiceURL = http://127.0.0.1:9000
Teil2: OpenSim.ini
Zitat:[Architecture]
Include-Architecture = "config-include/Standalone.ini"

OpenSimDefaults.ini
Zitat:[UserProfiles]
;# {ProfileURL} {} {Set url to UserProfilesService} {}
;; Set the value of the url to your UserProfilesService
;; If un-set / "" the module is disabled
;; If the ProfileURL is not set, then very BASIC
;; profile support will be configured. If the ProfileURL is set to a
;; valid URL, then full profile support will be configured. The URL
;; points to your grid's Robust user profiles service
;;
ProfileURL = http://127.0.0.1:9000

config-include/StandaloneCommon.ini
Zitat:[DatabaseService]
;
; ### Choose the DB
;

; SQLite
;Include-Storage = "config-include/storage/SQLiteStandalone.ini";

; MySql
; Uncomment these lines if you want to use mysql storage
; Change the connection string to your db details
StorageProvider = "OpenSim.Data.MySQL.dll"
ConnectionString = "Data Source=localhost;Database=opensim;User ID=opensim;Password=geheim;Old Guids=true;"

Teil 2: config-include/StandaloneCommon.ini
Zitat:;; UserProfiles Service
;;
;; To use, set Enabled to true then configure for your site...
[UserProfilesService]
LocalServiceModule = "OpenSim.Services.UserProfilesService.dll:UserProfilesService"
Enabled = true

;; Configure this for separate databse
ConnectionString = "Data Source=localhost;Database=opensim;User ID=opensim;Password=geheim;Old Guids=true;"
Realm = UserProfiles

UserAccountService = OpenSim.Services.UserAccountService.dll:UserAccountService
AuthenticationServiceModule = "OpenSim.Services.AuthenticationService.dllTongueasswordAuthenticationService"

Alles andere blieb unverändert und die Datenbank war komplett leer bzw. neu erstellt.

Fehlermeldung in der Console
Zitat:[LLCLIENTVIEW]: Exeception when handling generic message Das Objekt des Typs "OpenMetaverse.StructuredData.OSD" kann nicht in Typ "OpenMetaverse.StructuredData.OSDArray" umgewandelt werden. bei OpenSim.Region.OptionalModules.Avatar.UserProfiles.UserProfileModule.Classifieds​Request(Object sender, String method, List`1 args)

Fehlermeldungen im Viewer:
Es werden drei Nachrichtendialoge geöffnet welche jeweils folgenden Inhalt haben :
Error updating pickrequests
Error updating interests
Error updating properties

Zusammenfassung der Versionen:
Apache 2.4.3
PHP 5.4.7
MySQL 5.0.10
OpenSimulator 0.7.6
dotNet Framework 4.0

Ich vermute das bei einer leeren/neuen Datenbank die Tabelle "UserProfiles" samt Struktur gar nicht erst angelegt wird aus welchem Grund auch immer ...

@Catie ich hab alles so drin wie von dir beschrieben es funktioniert leider trotzdem nicht, vielleicht liegt es daran das alle Tabellen in der DB bei dir schon vorhanden waren da du (vermute ich mal) nicht komplett neu installiert hast.

Lukas Smile
Zitieren
#44
Ich hab es komplett neuinstalliert. Problem ist es ist echt schwer das genau nachzuvollziehen. Vielleicht liegt es auch daran das ich eine Dynamische IP gebrauche.
Zitieren
#45
Danke für deine Hilfe Catie Smile

Ich hab das jetzt aufgegeben und das OpenProfileModule genommen und den neuen kram deaktiviert. Bilder usw. funktionieren jetzt, somit hab ich mein Ziel erreicht Big Grin

Lukas Smile
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Profile Modul -> update ab r/17802 nötig MichelleArgus 0 1.424 14.01.2012, 18:09
Letzter Beitrag: MichelleArgus
  Profile-Problem Dorena Verne 10 6.045 09.05.2011, 13:52
Letzter Beitrag: Dorena Verne

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste