Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Arriba Settings
#1
Hallo zusammen

ich möchte mal Arriba testen und hab ne Frage zur gridcommon.ini
Code:
; **************************************************************************
; ***************  Die nachfolgenden Zeilen nicht veraendern!  *************
; ***************      Do not change the following lines!      *************
; **************************************************************************

[Hypergrid]
    HomeURI = "http://hypergrid.org:8002/"
    GatekeeperURI = "http://hypergrid.org:8002/"

[AssetService]
    DefaultAssetLoader = "OpenSim.Framework.AssetLoader.Filesystem.dll"
    AssetLoaderArgs = "assets/AssetSets.xml"
    AssetServerURI = "http://assets.hypergrid.org:8006"

[InventoryService]
    InventoryServerURI = "http://inventory.hypergrid.org:8005"

[GridInfo]
    GridInfoURI = "http://hypergrid.org:8002"

[GridService]
    GridServerURI = "http://grid.hypergrid.org:8000"
    AllowHypergridMapSearch = true
    ; MapTileDirectory = "./maptiles"
    Gatekeeper = "http://hypergrid.org:8002/"


Muss ich das tatsächlich so lassen oder muss ich das nun auf mein Server umstellen ?

Grüsse, Pharcide
Zitieren
#2
Es handelt sich, wie ich sehe um die Version von Mareta. Diese ist auf das Metrogrid zugeschnitten. Demnach musst du sie natürlich anpassen.
Einen "neutralen" Binärdownload findest du hier: https://github.com/ft-/arribasim-techpreview-builds

Die unterste ist die aktuellste.
Zitieren
#3
Danke Smile
Zitieren
#4
Irgendwie funzt das nicht.
Ich habe das bin Verzeichnis in die Diva Installation kopiert, und alles überschrieben.
Dann die Opensim Ini kopiert und die myWorld.ini kopiert (letzteres ins config_include)
beim Starten werden keine Konfig Dateien gefunden und gefragt ob ich die Examples kopiert hätte.
Dann hab ich dasselbe mit der schon installierten 0.8.2.1 Standard Installation gemacht, die Opensim.ini kopiert, und den Inhalt von der Diva myWorld.ini in die StandaloneCommon.ini kopiert.

Dasselbe Ergebnis.

Lokal auf meinem Laptop habe ich die 0.8.2.1 installiert, das in von Arriba drüberkopiert und kann die Sim (die einzelne Start Sim ohne DB), problemlos starten.
Was mache ich falsch ?

gruss, Pharcide
Zitieren
#5
So einfach die Arriba in die Diva quetschen geht gar nicht.
da die Arriba eher wie eine normale OpenSim wie in deinem Fall auf deinem Lapi konzipiert ist, geht das auch eher.
[-] The following 1 user says Thank You to Dorena Verne for this post:
  • Wollex Baily2
Zitieren
#6
Genau Dorena sagt es,erst Arriba Installieren und richtig zum laufen bringen.  ( mit Grid/Robust )
Dann die Diva Sachen rein und es geht dann los.... ( bei Windows 100% )
Hier unsere Diva mit Arriba : http://www.kikiandwollex.de:8002/wifi , bei uns habe ich die User Neuanmeldung raus gemacht weil ich wissen möchte wer bei uns ins Grid kommt.

Gruß Wollex
Zitieren
#7
Huhu

also ich hab vom oben genannten Link die Bin runtergeladen
diese in das leere Verzeichnis c:\arriba kopiert

Dann nach bestem Wissen und Gewissen die Datei GridCommon.ini und Opensim.ini angepasst nach dieser Anleitung:
https://hyperweb.eu/OpenSim_0.8/GridCommonIni, die URLs habe ich in der opensim.ini im Abschnitt [CONSt] festgelegt, und die verschiedenen URIs nicht wie im Tutorial beschrieben eingesetzt, sondern wie im Example, eben über diese CONST Variable nach dem Schema verwendet:
HomeURI = "${Const|BaseURL}:${Const|PublicPort}/"

In der Anleitung stehen aber Ports die nicht mit der Example übereinstimmen ? Zum Beispiel Port 8004 ?

Nach dem Starten von Opensim.exe werden schön brav die Datenbank angelegt und die ersten Abfragen kommen.
Nach dem Eingeben von Vor und Nachname kommt dieser Crash.

Wo könnte der böse Wurm sein Unwesen treibe ?

Grüsse, Pharcide
Zitieren
#8
Du bist ja wieder bei der Anleitung von Mareta für das Metrogrid^.
Poste doch mal den Teil der Logdatei wo der Simulator kracht.
[-] The following 1 user says Thank You to Dorena Verne for this post:
  • Wollex Baily2
Zitieren
#9
Ja ne andere Anleitung hab ich nicht gefunden, und versucht das anzupassen

Code:
2017-07-25 19:12:42,543 INFO  - OpenSim.Region.CoreModules.ServiceConnectorsOut.Neighbour.RemoteNeighbourServicesConnector [NEIGHBOUR CONNECTOR]: Enabled remote neighbours for region Kokomo
2017-07-25 19:12:42,543 INFO  - OpenSim.Region.CoreModules.ServiceConnectorsOut.Inventory.HGInventoryBroker [HG INVENTORY CONNECTOR]: Enabled HG inventory for region Kokomo
2017-07-25 19:12:42,546 INFO  - OpenSim.Region.CoreModules.ServiceConnectorsOut.Asset.HGAssetBroker [HG ASSET CONNECTOR]: Enabled hypergrid asset broker for region Kokomo
2017-07-25 19:12:42,546 INFO  - OpenSim.Region.CoreModules.ServiceConnectorsOut.Asset.HGAssetBroker [HG ASSET CONNECTOR]: Enabled asset caching for region Kokomo
2017-07-25 19:12:42,548 INFO  - OpenSim.Region.CoreModules.ServiceConnectorsIn.Simulation.SimulationServiceInConnectorModule [SIM SERVICE]: Starting...
2017-07-25 19:12:42,559 WARN  - OpenSim.Region.CoreModules.Framework.Search.BasicSearchModule [BASIC SEARCH MODULE]: Could not get IGroupsModule
2017-07-25 19:12:42,590 DEBUG - OpenSim.Region.DataSnapshot.DataSnapshotManager [DATASNAPSHOT]: Marking scene Kokomo as stale.
2017-07-25 19:12:42,604 DEBUG - OpenSim.Framework.Monitoring.Watchdog [WATCHDOG]: Started tracking thread InventoryWorkerThread0, ID 51
2017-07-25 19:12:42,604 DEBUG - OpenSim.Framework.Monitoring.Watchdog [WATCHDOG]: Started tracking thread InventoryWorkerThread1, ID 52
2017-07-25 19:12:42,638 DEBUG - OpenSim.Region.CoreModules.ServiceConnectorsOut.Authorization.AuthorizationService [AuthorizationService]: Region Kokomo access restrictions: None
2017-07-25 19:12:42,638 INFO  - OpenSim.Region.CoreModules.ServiceConnectorsOut.Authorization.LocalAuthorizationServicesConnector [AUTHORIZATION CONNECTOR]: Enabled local authorization for region Kokomo
2017-07-25 19:12:42,638 INFO  - OpenSim.Region.CoreModules.Scripting.ScriptModuleComms.ScriptModuleCommsModule [MODULE COMMANDS]: Script engine found, module active
2017-07-25 19:12:42,667 DEBUG - OpenSim.Region.OptionalModules.Avatar.Attachments.TempAttachmentsModule [TEMP ATTACHS]: Registered script functions
2017-07-25 19:13:01,609 INFO  - OpenSim.Framework.SynchronousRestFormsRequester [FORMS]: Error sending request to http://rouken.de:8003/accounts: Die Verbindung mit dem Remoteserver kann nicht hergestellt werden.. Request: VERSIONMIN=0&VERSIONMAX=1&METHOD=getaccount&ScopeID=00000000-0000-0000-0000-000000000000&FirstName=tim&LastName=tom
2017-07-25 19:13:01,609 DEBUG - OpenSim.Services.Connectors.UserAccountServicesConnector [ACCOUNT CONNECTOR]: Exception when contacting user accounts server at http://rouken.de:8003/accounts: Die Verbindung mit dem Remoteserver kann nicht hergestellt werden.
2017-07-25 19:13:01,629 ERROR - OpenSim.Application [APPLICATION]: 
APPLICATION EXCEPTION DETECTED: System.UnhandledExceptionEventArgs

Exception: System.Xml.XmlException: Das Stammelement ist nicht vorhanden.
   bei System.Xml.XmlTextReaderImpl.Throw(Exception e)
   bei System.Xml.XmlTextReaderImpl.ParseDocumentContent()
   bei System.Xml.XmlLoader.Load(XmlDocument doc, XmlReader reader, Boolean preserveWhitespace)
   bei System.Xml.XmlDocument.Load(XmlReader reader)
   bei System.Xml.XmlDocument.LoadXml(String xml)
   bei OpenSim.Server.Base.ServerUtils.ParseXmlResponse(String data)
   bei OpenSim.Services.Connectors.UserAccountServicesConnector.SendAndGetReply(Dictionary`2 sendData)
   bei OpenSim.Services.Connectors.UserAccountServicesConnector.GetUserAccount(UUID scopeID, String firstName, String lastName)
   bei OpenSim.Region.CoreModules.ServiceConnectorsOut.UserAccounts.RemoteUserAccountServicesConnector.GetUserAccount(UUID scopeID, String firstName, String lastName)
   bei OpenSim.OpenSimBase.SetUpEstateOwner(Scene scene)
   bei OpenSim.OpenSimBase.CreateRegion(RegionInfo regionInfo, Boolean portadd_flag, Boolean do_post_init, IScene& mscene)
   bei OpenSim.ApplicationPlugins.LoadRegions.LoadRegionsPlugin.PostInitialise()
   bei OpenSim.OpenSimBase.StartupSpecific()
   bei OpenSim.OpenSim.StartupSpecific()
   bei OpenSim.Framework.Servers.BaseOpenSimServer.Startup()
   bei OpenSim.Application.Main(String args)

Application is terminating: True

//Edit: Habs mal ein wenig leserlicher gemacht ;D @Bogus
Zitieren
#10
Hallo ;D

Bei solchen langen logs ist es meist hilfreich, solche Dienste wie PasteIn zu nutzen, hier mal ein Link, der ist kostenlos nutzbar, ganz ohne Werbung Big Grin oder in ein Code-Block zu setzen ;D

https://paste.md-5.net/
Tschöö

Bogus | PinguinsReisen.de
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Mit Arriba-Minigrid auf neuen Rechner umziehen Moe McAlpine 2 329 11.08.2017, 10:06
Letzter Beitrag: Moe McAlpine
  neueste arriba und diva wifi hajo drechsler 11 1.075 03.08.2017, 22:55
Letzter Beitrag: Dorena Verne
  Arriba oder Vanilla? Dorena Verne 25 2.589 31.07.2017, 13:59
Letzter Beitrag: Dorena Verne
  Arriba Minigrid: Region lässt sich nicht löschen bengl1984 5 1.040 31.01.2017, 17:20
Letzter Beitrag: Manfred Aabye
  Arriba-Minigrid - Füße sind verbogen ^^ bengl1984 1 576 14.01.2017, 21:30
Letzter Beitrag: Bogus Curry

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste