Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Arriba: Munteres drauf los Testen
#21
(11.05.2014, 09:57)Bogus Curry schrieb:
(11.05.2014, 09:44)Dorena Verne schrieb: Habe den neusten Repo lokal gestartet,..keine Probleme.Cool

unter Windows ?

Ja,Bogus unter Windows.Wink
Zitieren
#22
Wenn der letzte Stand noch Probleme macht bei dir, dann bitte mal die Konfiguration ohne Passwörter per PN. Leider gibt es sehr oft alte Konfigurationen, die kleinere Fehler enthalten.

Eventuell auch den Abschnitt des Logs mit der Fehlermeldung sofern vorhanden.
Die ganze Welt ist ein Irrenhaus und wir sind nur die Kandidaten  ;)
Zitieren
#23
Passwörter hab ich nicht vergeben müssen, hab SQLIte benutzen wollen, aber beim start von OpenSim.exe hat er einige Errors gemacht

Hier die log Datei
Code:
2014-05-11 04:38:34,461 INFO  - OpenSim.Application [OPENSIM MAIN]: configured log4net using default OpenSim.exe.config
2014-05-11 04:38:34,487 INFO  - OpenSim.Application [OPENSIM MAIN]: System Locale is en-US
2014-05-11 04:38:34,491 INFO  - OpenSim.Application [OPENSIM MAIN]: Environment variable MONO_THREADS_PER_CPU is unset
2014-05-11 04:38:34,491 INFO  - OpenSim.Application [OPENSIM MAIN]: Runtime gave us 3 min worker threads and 6 min IOCP threads
2014-05-11 04:38:34,492 INFO  - OpenSim.Application [OPENSIM MAIN]: Runtime gave us 300 max worker threads and 12 max IOCP threads
2014-05-11 04:38:34,492 INFO  - OpenSim.Application [OPENSIM MAIN]: Bumping up to max worker threads to 500
2014-05-11 04:38:34,492 INFO  - OpenSim.Application [OPENSIM MAIN]: Bumping up max IOCP threads to 1000
2014-05-11 04:38:34,492 INFO  - OpenSim.Application [OPENSIM MAIN]: Threadpool set to 500 max worker threads and 1000 max IOCP threads
2014-05-11 04:38:34,514 INFO  - OpenSim.Application [OPENSIM MAIN]: Environment is supported by OpenSimulator.
2014-05-11 04:38:34,564 INFO  - OpenSim.ConfigurationLoader [CONFIG]: Reading configuration settings
2014-05-11 04:38:34,565 INFO  - OpenSim.ConfigurationLoader [CONFIG]: Reading configuration file /home/linadmin/opensim/arriba-dev/bin/OpenSimDefaults.ini
2014-05-11 04:38:34,586 INFO  - OpenSim.ConfigurationLoader [CONFIG]: Loading environment variables for Config
2014-05-11 04:38:34,605 INFO  - OpenSim.OpenSim [OPENSIM MAIN]: Using async_call_method SmartThreadPool
2014-05-11 04:38:34,616 INFO  - OpenSim.OpenSim ====================================================================
2014-05-11 04:38:34,616 INFO  - OpenSim.OpenSim ========================= STARTING OPENSIM =========================
2014-05-11 04:38:34,616 INFO  - OpenSim.OpenSim ====================================================================
2014-05-11 04:38:34,621 INFO  - OpenSim.Framework.Servers.ServerBase [SERVER BASE]: Starting in /home/linadmin/opensim/arriba-dev/bin
2014-05-11 04:38:34,621 INFO  - OpenSim.Framework.Servers.ServerBase [SERVER BASE]: OpenSimulator version: OpenSim Arriba (Codename: That is Not True) Dev521ec34
2014-05-11 04:38:34,621 INFO  - OpenSim.Framework.Servers.ServerBase [SERVER BASE]: Operating system version: Unix 3.10.29.86, .NET platform Unix, 64-bit
2014-05-11 04:38:34,625 INFO  - OpenSim.Framework.Servers.ServerBase [SERVER BASE]: Logging started to file /home/linadmin/opensim/arriba-dev/bin/OpenSim.log
2014-05-11 04:38:34,668 ERROR - OpenSim.Application [APPLICATION]:
APPLICATION EXCEPTION DETECTED: System.UnhandledExceptionEventArgs

Exception: System.Exception: Configuration file is missing the [SimulationDataStore] section.  Have you copied OpenSim.ini.example to OpenSim.ini to reference config-include/ files?
  at OpenSim.OpenSimBase.StartupSpecific () [0x00000] in <filename unknown>:0
  at OpenSim.OpenSim.StartupSpecific () [0x00000] in <filename unknown>:0
  at OpenSim.Framework.Servers.BaseOpenSimServer.Startup () [0x00000] in <filename unknown>:0
  at OpenSim.Application.Main (System.String[] args) [0x00000] in <filename unknown>:0

Application is terminating: True

2014-05-11 04:40:13,160 INFO  - OpenSim.Application [OPENSIM MAIN]: configured log4net using default OpenSim.exe.config
2014-05-11 04:40:13,186 INFO  - OpenSim.Application [OPENSIM MAIN]: System Locale is en-US
2014-05-11 04:40:13,191 INFO  - OpenSim.Application [OPENSIM MAIN]: Environment variable MONO_THREADS_PER_CPU is unset
2014-05-11 04:40:13,191 INFO  - OpenSim.Application [OPENSIM MAIN]: Runtime gave us 3 min worker threads and 6 min IOCP threads
2014-05-11 04:40:13,191 INFO  - OpenSim.Application [OPENSIM MAIN]: Runtime gave us 300 max worker threads and 12 max IOCP threads
2014-05-11 04:40:13,192 INFO  - OpenSim.Application [OPENSIM MAIN]: Bumping up to max worker threads to 500
2014-05-11 04:40:13,192 INFO  - OpenSim.Application [OPENSIM MAIN]: Bumping up max IOCP threads to 1000
2014-05-11 04:40:13,192 INFO  - OpenSim.Application [OPENSIM MAIN]: Threadpool set to 500 max worker threads and 1000 max IOCP threads
2014-05-11 04:40:13,214 INFO  - OpenSim.Application [OPENSIM MAIN]: Environment is supported by OpenSimulator.
2014-05-11 04:40:13,265 INFO  - OpenSim.ConfigurationLoader [CONFIG]: Reading configuration settings
2014-05-11 04:40:13,265 INFO  - OpenSim.ConfigurationLoader [CONFIG]: Reading configuration file /home/linadmin/opensim/arriba-dev/bin/OpenSimDefaults.ini
2014-05-11 04:40:13,286 INFO  - OpenSim.ConfigurationLoader [CONFIG]: Reading configuration file /home/linadmin/opensim/arriba-dev/bin/OpenSim.ini
2014-05-11 04:40:13,295 INFO  - OpenSim.ConfigurationLoader [CONFIG]: Reading configuration file /home/linadmin/opensim/arriba-dev/bin/config-include/Standalone.ini
2014-05-11 04:40:13,299 WARN  - OpenSim.ConfigurationLoader [CONFIG]: Could not find include file /home/linadmin/opensim/arriba-dev/bin/config-include/StandaloneCommon.ini
2014-05-11 04:40:13,299 INFO  - OpenSim.ConfigurationLoader [CONFIG]: Loading environment variables for Config
2014-05-11 04:40:13,319 INFO  - OpenSim.OpenSim [OPENSIM MAIN]: Using async_call_method SmartThreadPool
2014-05-11 04:40:13,328 INFO  - OpenSim.OpenSim ====================================================================
2014-05-11 04:40:13,328 INFO  - OpenSim.OpenSim ========================= STARTING OPENSIM =========================
2014-05-11 04:40:13,328 INFO  - OpenSim.OpenSim ====================================================================
2014-05-11 04:40:13,334 INFO  - OpenSim.Framework.Servers.ServerBase [SERVER BASE]: Starting in /home/linadmin/opensim/arriba-dev/bin
2014-05-11 04:40:13,334 INFO  - OpenSim.Framework.Servers.ServerBase [SERVER BASE]: OpenSimulator version: OpenSim Arriba (Codename: That is Not True) Dev521ec34
2014-05-11 04:40:13,335 INFO  - OpenSim.Framework.Servers.ServerBase [SERVER BASE]: Operating system version: Unix 3.10.29.86, .NET platform Unix, 64-bit
2014-05-11 04:40:13,341 INFO  - OpenSim.Framework.Servers.ServerBase [SERVER BASE]: Logging started to file /home/linadmin/opensim/arriba-dev/bin/OpenSim.log
2014-05-11 04:40:13,375 ERROR - OpenSim.Server.Base.ServerUtils [SERVER UTILS]: Error loading plugin OpenSim.Region.Framework.Interfaces.ISimulationDataService from OpenSim.Services.Connectors.dll. Exception: No StorageProvider configured
System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.Exception: No StorageProvider configured
  at OpenSim.Services.Connectors.SimulationDataService..ctor (IConfigSource config) [0x00000] in <filename unknown>:0
  at (wrapper managed-to-native) System.Reflection.MonoCMethod:InternalInvoke (System.Reflection.MonoCMethod,object,object[],System.Exception&)
  at System.Reflection.MonoCMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00000] in <filename unknown>:0
  --- End of inner exception stack trace ---
  at System.Reflection.MonoCMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00000] in <filename unknown>:0
  at System.Reflection.MonoCMethod.Invoke (BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00000] in <filename unknown>:0
  at System.Activator.CreateInstance (System.Type type, BindingFlags bindingAttr, System.Reflection.Binder binder, System.Object[] args, System.Globalization.CultureInfo culture, System.Object[] activationAttributes) [0x00000] in <filename unknown>:0
  at System.Activator.CreateInstance (System.Type type, System.Object[] args, System.Object[] activationAttributes) [0x00000] in <filename unknown>:0
  at System.Activator.CreateInstance (System.Type type, System.Object[] args) [0x00000] in <filename unknown>:0
  at OpenSim.Server.Base.ServerUtils.LoadPlugin[ISimulationDataService] (System.String dllName, System.String className, System.Object[] args) [0x00000] in <filename unknown>:0
2014-05-11 04:40:13,380 ERROR - OpenSim.Server.Base.ServerUtils [SERVER UTILS]: Error loading plugin OpenSim.Services.Connectors.dll: Exception has been thrown by the target of an invocation. args.Length 1
2014-05-11 04:40:13,381 ERROR - OpenSim.Application [APPLICATION]:
APPLICATION EXCEPTION DETECTED: System.UnhandledExceptionEventArgs

Exception: System.Exception: Could not load an ISimulationDataService implementation from OpenSim.Services.Connectors.dll:SimulationDataService, as configured in the LocalServiceModule parameter of the [SimulationDataStore] config section.
  at OpenSim.OpenSimBase.StartupSpecific () [0x00000] in <filename unknown>:0
  at OpenSim.OpenSim.StartupSpecific () [0x00000] in <filename unknown>:0
  at OpenSim.Framework.Servers.BaseOpenSimServer.Startup () [0x00000] in <filename unknown>:0
  at OpenSim.Application.Main (System.String[] args) [0x00000] in <filename unknown>:0

Application is terminating: True

In der OpenSim.ini hab ich unten nur die Standalone.ini auskommentiert. Und danach halt OpenSim.exe gestartet
Tschöö

Bogus | PinguinsReisen.de
Zitieren
#24
hast du im config-include Verzeichnis die standaloneCommon.ini.examlpe in ini umbenannt?
Bzw editiert?
Zitieren
#25
Hallo Bogus,

Dies hier erklärt das Startup-Problem:
2014-05-11 04:40:13,295 INFO - OpenSim.ConfigurationLoader [CONFIG]: Reading configuration file /home/linadmin/opensim/arriba-dev/bin/config-include/Standalone.ini
2014-05-11 04:40:13,299 WARN - OpenSim.ConfigurationLoader [CONFIG]: Could not find include file /home/linadmin/opensim/arriba-dev/bin/config-include/StandaloneCommon.ini

und

No StorageProvider configured

----------------------------
soll die Sim ans Grid dann bitte die

; Include-Architecture = "config-include/GridHypergrid.ini"

aktivieren und eine GridCommon.ini bereitstellen.

----------------------------
Im Falle eines Nicht-HG-Standalones

Include-Architecture = "config-include/Standalone.ini"

und eine StandaloneCommon.ini erstellen

----------------------------
Im Falle eines HG-Standalones

Include-Architecture = "config-include/Standalone.ini"

und ebenfalls eine StandaloneCommon.ini erstellen
Die ganze Welt ist ein Irrenhaus und wir sind nur die Kandidaten  ;)
Zitieren
#26
Huhu

Auch von mir ein herzlich willkommen Freaky, ich hoffe nur das dieser Fork mal laenger Lebt und vieleicht wenigstens hiermit dann die Simgrenzen geschichte werden ohne Varioregion nuetzen zu muessenWink

Auf jedenfall klasse,das es nun ein neues Project gibt, und das sogar endlich mal Deutschsprachig,denn das fehlte bisher komplett

lg
Ezry
Nichts im Leben ist ein Muss!!!!!!!!!!!..............Alles ein Kann!!!!!


http://angels-world.selfhost.eu:8002
Zitieren
#27
Ja die Sim-Grenzen sind mir auch ein Anliegen, das flüssig hinzubekommen.

Aber erst mal stehen diese Mengen an ungelösten Problemen des OpenSim an.
Die ganze Welt ist ein Irrenhaus und wir sind nur die Kandidaten  ;)
Zitieren
#28
OpenSimSearch und OpenSimProfile habe ich mit ins Repo integriert, da durch ein paar sinnvolle Lib-Updates die bisher verfügbaren fertigen Kompilate nicht mehr passen.
Die ganze Welt ist ein Irrenhaus und wir sind nur die Kandidaten  ;)
Zitieren
#29
Hallo,
ich habe mir vorhin die Sourcen gezogen und durch den Compiler gejagt, funktioniert soweit auch ganz gut. Mit dem Hypergrid konnte ich auch einwandfrei hin und her hüpfen und ein paar Sachen mitnehmen. Scheinbar ist was mit dem Profil Modul noch nicht alles im trockenen aber als ich es aus dem bin Verzeichnis kurzer Hand rausnahm läufts wie geschmiert.

Ich hab nur einen kleinen vServer zum basteln und testen, Arriba läuft im Standalone Hypergrid Modus mit SQLite.

Ich hoffe ihr bleibt dran und wünsch euch mit eurem Fork viel Erfolg, ich behalte euer Projekt im Blick und teste wie alle anderen auch weiterhin die neuen Sourcen Smile
Zitieren
#30
Es kann sein, dass es nicht korrekt deaktiviert werden kann, da es bisher noch nie in der Form betrieben wurde.
Die ganze Welt ist ein Irrenhaus und wir sind nur die Kandidaten  ;)
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Arriba-Sim: Binärdownload für Metropolis (inoffiziell) Mareta Dagostino 74 37.371 05.10.2017, 00:39
Letzter Beitrag: Mareta Dagostino
  Mesh-Problem Arriba Dorena Verne 11 1.064 06.08.2017, 08:31
Letzter Beitrag: Dorena Verne
  neue Version von Arriba on Stick Beacara 39 10.463 21.02.2017, 23:39
Letzter Beitrag: Dorena Verne
  "Arriba-Minigrid" (Windows) Dorena Verne 82 47.248 18.02.2017, 16:00
Letzter Beitrag: Mareta Dagostino
  Umzug von Opensim nach Arriba Pharcide 3 1.293 14.08.2016, 15:34
Letzter Beitrag: Dorena Verne

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 2 Gast/Gäste